Enyo
  1. Enyo
  2. ENYO-2063

Ares should work on Node.js 0.10.x

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: None None
    • Resolution: Fixed
    • Fix Version/s: ares-0.2.2
    • Component/s: ares
    • Labels:
      None
    • Story Points:
      25
    • Epic Link:
    • Sprint:
      Sprint end 7/10 - HP, On Deck HP, Sprint 13 end 14/8 - HP

      Description

      Support Ares on node 0.10.x

        Issue Links

          Activity

          Hide
          Yevgen Sukharenko added a comment -

          I believe problem somewhere here:
          ares WARN genZip TypeError: listener must be a function

          I will re-test from office on Win PC, but on my Mac right now I got this error message.

          Show
          Yevgen Sukharenko added a comment - I believe problem somewhere here: ares WARN genZip TypeError: listener must be a function I will re-test from office on Win PC, but on my Mac right now I got this error message.
          Hide
          Yevgen Sukharenko added a comment -

          One sec - I will try to re-init my local git and update everything.

          Show
          Yevgen Sukharenko added a comment - One sec - I will try to re-init my local git and update everything.
          Hide
          FiX Kowalski (Ares Team) added a comment -

          The signature of Generator#generate has changed, so the fact that a parameter has the wrong type does not look surprising to me. Did you update the sub-modules?

          Show
          FiX Kowalski (Ares Team) added a comment - The signature of Generator#generate has changed, so the fact that a parameter has the wrong type does not look surprising to me. Did you update the sub-modules?
          Hide
          Yevgen Sukharenko added a comment -

          I just remove everything, clone again, with all submodules, npm update, etc...
          And right now it looks good. Maybe something was wrong with my local copy.
          Anyway - I can create project now and not found any other problems after migrate to NodeJS 0.10.x.

          Show
          Yevgen Sukharenko added a comment - I just remove everything, clone again, with all submodules, npm update, etc... And right now it looks good. Maybe something was wrong with my local copy. Anyway - I can create project now and not found any other problems after migrate to NodeJS 0.10.x.
          Hide
          Yevgen Sukharenko added a comment -

          After PR 455 no more problem found related to migrating to NodeJS 0.10.x.
          Ares IDE officially confirmed with NodeJS 0.10.
          Closing ticket.

          Show
          Yevgen Sukharenko added a comment - After PR 455 no more problem found related to migrating to NodeJS 0.10.x. Ares IDE officially confirmed with NodeJS 0.10. Closing ticket.

            People

            • Assignee:
              Yevgen Sukharenko
              Reporter:
              Yves Del Medico (Ares Team)
            • Votes:
              1 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Agile